Performing configuration backups on MikroTik devices is essential to avoid risks when problems occur. Backups allow us to quickly restore settings, reducing downtime and keeping systems running. Without backups, rebuilding the configuration from scratch can be time-consuming and increases the chance of errors or missed settings.
In this lab, I have two MikroTik routers. The first one is already configured, and the second one is a new MikroTik with no configuration.
I’m going to create a backup on the first router and then restore it onto the second one.
Tip: If you are doing this on real devices, make sure both routers are the same MikroTik model. Otherwise, some configurations might not be compatible and could cause issues after the restore.
Here is the first router configuration
/system identity
set name=MyRouter
/interface bridge
add name=LAN-BRIDGE
add name=WAN-BRIDGE
/interface bridge port
add bridge=WAN-BRIDGE interface=ether1
add bridge=LAN-BRIDGE interface=ether2
add bridge=LAN-BRIDGE interface=ether3
add bridge=LAN-BRIDGE interface=ether4
/ip dhcp-client
add interface=WAN-BRIDGE
/ip address
add address=192.168.1.1/24 interface=LAN-BRIDGE network=192.168.1.0
/ip firewall nat
add action=masquerade chain=srcnat out-interface=WAN-BRIDGE
/ip pool
add name=lan1-pool ranges=192.168.1.10-192.168.1.200
/ip dhcp-server
add address-pool=lan1-pool interface=LAN-BRIDGE name=dhcp-server-lan1
/ip dhcp-server network
add address=192.168.1.0/24 dns-server=8.8.8.8 gateway=192.168.1.1 netmask=24
Create backup without password
system backup save name="backup_20250428.backup"
Create backup with password
system backup save name="backup_20250428.backup" password="StrongPassword"
After creating the backup, you will see a backup file. You can download it directly via winbox and transfer it to the target device.
[admin@MyRouter] > file print
Columns: NAME, TYPE, SIZE, CREATION-TIME
# NAME TYPE SIZE CREATION-TIME
0 skins directory apr/28/2025 07:42:44
1 backup_20250428.backup backup 23.6KiB apr/28/2025 11:38:45
2 pub directory apr/28/2025 08:05:50
If SSH is enabled on both routers, you can transfer the backup file directly using scp or another SSH file transfer tool:
scp [email protected]:/backup_20250428.backup [email protected]:/backup_20250428.backup
Make sure the backup file exists on the new router by listing the files:
[admin@MikroTik] > file print
Columns: NAME, TYPE, SIZE, CREATION-TIME
# NAME TYPE SIZE CREATION-TIME
0 skins directory apr/28/2025 07:52:09
1 backup_20250428.backup backup 23.6KiB apr/28/2025 11:41:56system backup load name=backup_20250428.backup
If backup is created without password
system backup load name=backup_20250428.backup
If backup is created with password
system backup load name=backup_20250428.backup password="StrongPassword"
After this the device will reboot it self and start with new configuration.